InstallationΒΆ

Pybinding can be installed on Windows, Linux or Mac, with the following prerequisites:

  • Python 3.4 or newer (Python 2.x is not supported)
  • The SciPy stack of scientific packages, with required versions:
    • numpy >= v1.9
    • scipy >= v0.15
    • matplotlib >= v1.5
  • If you’re using Linux, you’ll also need GCC >= v4.8 and CMake >= v3.0.

You can install all of this in two ways:

If you are new to Python/SciPy or if you’re just not sure how to proceed, go with the Quick Install option. It will show you how to easily setup a new Python environment and install everything. That quick guide will be everything you need in most cases. However, If you would like a custom setup within your existing Python environment and you have experience compiling binary packages, you can check out the Advanced Install option.